Browser Requirements

NCSBN recently implemented additional security enhancements to its sites and applications. Effective June 2016 visitors using older browsers may not be able to access some NCSBN websites. To ensure security and the best site experience, visitors to NCSBN websites should use an updated browser.

Supported Browsers

  • Internet Explorer (IE) 11
  • Firefox 27 or higher
  • Google Chrome 38 or higher
  • Microsoft Edge
  • Safari on Mac OSX 10.9 or higher

Check the browser version you are using by looking in the settings or by clicking on the “About [browser]” in the menu of each browser. Most browsers will provide instructions for updating to the latest versions.

Last Updated: 6/29/2016